Upgrade de libc6 2.13 en huayra 2.0

Hola Amigos me encontré con el problema de querer instalar Popcorn Time y Godot Engine en Huayra 2.0

Los problemas puntuales al intentar ejecutar los programas eran

a. “error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory”

b. versionGLIBC_2.15′ not found (required by …)

Bueno el error 1 se puede solucionar instalando libudev.so.1 y haciendo un link simbólico con
sudo ln -s /lib/i386-linux-gnu/libudev.so.1 /usr/lib/libudev.so.1
esta solución no importa porque la que funcionó es la siguiente:

1. Agregar la siguiente línea en /etc/apt/sources.list y guardar el archivo (asegurarse de tener los permisos necesarios)

deb http://ftp.debian.org/debian sid main

 

O bien

* En el synaptic -> Configuración -> Repositorios
En la pestaña Other Software hacer click en Add… y pegar la siguiente línea que corresponde al repositorio de la versión testing de debian que contiene paquetes mas actualizados.
deb http://ftp.debian.org/debian sid main

y luego click en Añadir origen

huayra

 

2. Cerrar synaptic en caso de haberlo usado y actualizar los repositorios en terminal con:

sudo apt-get update

3. Instalar los paquetes actualizados
sudo apt-get install libc6-amd64 libc6-dev libc6-dbg

Con eso tenemos actualizados los paquetes necesarios y los 2 softwares nombrados al principio pueden correr sin problemas, si hay alguna otra solución favor de compartir.

Dejá una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: